
Workstation Requirements and Course Troubleshooting Guide 

Workstation Requirements 08-17-2016 1 © 2016 SumTotal Systems, LLC, a Skillsoft company 

 

 

 
REQUIREMENTS OVERVIEW 
The following document provides segments from 
common issues Customer Support encounters in the 
day-to-day support of learners. It is meant to serve as a 
guide, rather than a binding statement of functionality. 
This guide assists with the troubleshooting of these 
common issues. 

 

If the learner continues to experience these issues or 
other related items pertaining to the Learning 
Management System, please contact us so that we may 
provide further assistance. 

 
INTERNET CONNECTION 
 

High-Speed Internet Connection: ensures the best 
Learner experience with online courses. 

 

Dial-Up Connection: may take several minutes to 
load the course pages and is not recommended for 
most courses that require more bandwidth. 

 

VPN: Customers who are on VPN may experience 
some issues in areas of the LMS that require 
maintaining a constant connection (for example: 
completing courses, uploading course packages, and 
Batch Uploads). 

 
SUPPORTED INTERNET BROWSERS 
Internet Explorer versions 9 through 11 
Mozilla Firefox – most recent version 
Google Chrome – most recent version 
• native browser on Android tablets 

Edge – most recent version 
• native browser on Microsoft Surface Tablets 

Safari – native version 
• native browser on Apple Tablets 

 
In general, core functionality within the LMS remains 
constant within these browsers. 
 

Support and testing is for native browsers and 
functionality on devices listed above. Java and Flash 
depending content is not natively supported.

RESETTING PASSWORDS AND USERNAME 
REMINDERS 

The Learning Management System provides learners 
the option of requesting a password reset or a 
username reminder using the Forgot Password link on 
the log in screen. 
• For passwords, this option requires that the learner’s 

user profile contains an email address in the system. 
Once reset, a temporary password is sent to the 
learner from  noreply@sumtotalsystems.com. 

• The account username is also sent as a reminder. 
 
When a user’s password expires, based on the 
domain’s security settings, the user is prompted to set a 
new password. On that page, the field labels correspond 
to the following. 
• Old Password = the value that the user just 

attempted to log in with. 
• New Password = the new value that the user 

must set before continuing into the LMS. 
• Confirm New Password = New Password. 

 
COURSE LAUNCH 
1) My course does not launch when I click the link on 

the Course Activities page. 
2) I click on the course link and I receive a blank window. 
3) The course window opens after I click the course link, 
but the course content does not load. 
 
Refer to the following sections for assistance: 
1. Popup Blockers 
2. Internet Options 
3. Plug-ins 
 
Specific courseware vendors may have browser 
requirements that must be met for the courses to 
function properly. 
 
COURSE COMPLETION CERTIFICATE 
I completed the course, but I cannot access the 
Completion Certificate.  
 
• Refresh the browser page. 
• Install Adobe Reader 9.0 or higher. 
• Certificate opens in a new window because pop-up 

blocker is disabled. 

COURSE STATUS 
1) I completed the course, but the status remains as 

Not Attempted. 
2) I completed the course, but the status remains as 

In Progress. 
 
• The Exit feature within the course bookmarks 

and saves the course information. 
• Verify all sections of the course are complete. 
• If a test is required for completion, ensure the test 

is complete. 
• If the course does not complete, refresh the 

browser page. 
• Some courses require that every page be viewed in 

order to be completed. 
• Do not use the red “X” to exit the course unless this is 

the only Exit option available. 
 
Refer to the following sections for additional assistance: 
1. Internet Options 
2. Java Settings 
3. Plug-ins 
4. Cookies and Scripting 
5. Firewalls 
 
INTERNET OPTIONS 
1. Navigate to Tools > Internet Options. 

a. General tab 
• Click Delete under Browsing History 
• Select the first four checkboxes 
• Click Delete and click OK 

b. Security tab 
• Click Default Level 
• Set the security level to Medium-high 
• Click Apply and click OK 

c. Privacy tab 
• Set the privacy level to Medium 
• Disable the popup blocker 

2. Restart your workstation 
 

OTHER SETTINGS 
Cookies and Scripting: should be enabled on the 
learner’s workstation in order to allow courseware 
bookmarking. 

mailto:noreply@sumtotalsystems.com
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POP-UP BLOCKERS INTERNET EXPLORER 9 AND HIGHER

 
INTERNET EXPLORER 
Navigate to Tools > Pop-up Blocker > Turn off Pop-
up Blocker 

 
1. Right-click on the File menu. 
2. Uncheck everything except Standard Buttons, 

Address Bar, Links, and Lock the Toolbars. 
• Google and Yahoo toolbars may have pop- up 

blockers inside them. 
 

To disable third party tool bars with pop up blockers: 
1. Navigate to Tools > Internet Options. 
2. Click on the Advanced Tab. 
3. Scroll to the Browsing section and uncheck the box 

next to ‘Enable third-party browser extensions’. 
4. Close and reopen Internet Explorer for these 

changes to take effect. 
 

MOZILLA FIREFOX 
1. Navigate to Tools > Options. 
2. Click the Content tab. 
3. Click Exceptions. 
4. Type https://services.geolearning.com in the 

Address of website: field. 
5. Click Allow, click Close, and click OK. 

 
GOOGLE CHROME 
1. Click on the icon with three horizontal bars. 
2. Click Settings. A new window opens. 
3. Scroll to the bottom of the page and click the link 

that says Show Advanced Settings. 
4. Under Privacy, click Content Settings. 
5. Under Pop-ups, click Manage Exceptions. 
6. Add https://services.geolearning.com and verify 

that Allow is selected for the Behavior. 
7. Click Done, Done, and close the Settings window. 

As of the April 2016 release, Maestro core functionality 
no longer supports Microsoft Internet Explorer 8.  
Many of the products that we implement with have either 
stopped support or have notified us of their plan to stop 
support this year. If users continue to use IE 8 after the 
April 2016 release, some features and functionality may 
not function properly within the IE 8 browser. Defects or 
performance issues that appear only in non-supported 
browsers will not be investigated or addressed after the 
April 2016 release. 

Previous versions of unsupported browsers continue to 
work with Maestro. However, if a specific issue is 
reported and research shows that upgrading to a 
supported version of Internet Explorer addresses the 
issue, that browser upgrade is the 'fix'. We will not devote 
development resources to change the code in any way to 
support IE 8. 

Some UI updates that we introduce may not display the 
same in IE 8 as in newer versions and other browsers. 
This is because the tools that we use no longer support 
IE 8. 

Our recommendation is to update to IE 10 for users who 
access the Advanced Reporting module in Maestro.  
All other users are recommended to upgrade to the latest 
version of Internet Explorer which is currently IE 11. 

If you are on the Integrated suite, we will support IE 8 
until you upgrade to Winter 2016. 

 

CLEAR CACHE 
1. Navigate to Tools > Internet Options. 
2. In the Browsing History section, click the Delete  
     button. 
3. Select the first four checkboxes. 
4. Click Delete. 
5. Click OK at the bottom of the Internet Options 

window. 
6. Close and reopen browser for these changes to 

take effect. 
 
COOKIES AND SCRIPTING 
1. Navigate to Tools > Internet Options. 
2. Click the Security tab. 
3. Click the Custom Level button. 
4. Under the Reset custom settings section, select 

Medium from the Reset to drop-down. 
5. Click Reset. 
6. To confirm the change, click Yes. 
7. Click OK. 
8. Click OK. 
 
 
FIREWALL 
A learner may have issues due to a firewall blocking 
the Internet pages. 
Common Firewall Programs: 

• Norton Internet Security 
• McAfee Privacy Service 

We recommend temporarily disabling these programs

https://services.geolearning.com/
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ADOBE FLASH 

PLUG-INS JAVA SECURITY WARNINGS  
WHEN LAUNCHING SKILLSOFT COURSES 

OR 
1. Click on your Windows Start button. 
2. Click on Control Panel. 
3. Click on Programs. 
4. Click on Uninstall a program. 
5. Adobe Flash Player is one of the first items listed.   
If the version not listed, select the program name and 
reference the links at the bottom of the window. 

 
Articulate courses may not work with Adobe version 9 
or higher. 

 
Additional plugins may be required by your courseware 
vendor. 

 
JAVA – INTERNET EXPLORER 
Setting Internet Options 

  1. Navigate to Tools > Internet Options. 
2. Click the Advanced tab. 
3. In the Browsing section, check both Disable Script 
Debugging options. 

 
ENABLING JAVA ADD-ONS 
1. Navigate to Tools > Manage add-ons. 
2. Verify that Toolbars and Extensions are selected in 
the Add-on Types column. 
3. At the bottom of the Add-on Types column in the 
Show drop-down menu, select All add-ons. 
4. On the main part of the window, scroll down to the 
Oracle America, Inc. section. 

a. Verify that all add-ons display as Enabled in the 
Status column. 

b. If an add-on is Disabled, click on the add-on name. 
c. An Enable button appears in the lower right 

corner. If the button is grayed out, verify that you 
are logged into your computer with an Admin 
account.  

 
NOTE:  If the Oracle America, Inc. section does not 
show, this indicates that Java is not currently installed. 

"ERROR LOADING COURSE CONTENT"  
IN SYNTRIO COURSES 

 

Both of these issues have been identified after a recent 
update to Oracle's Security Platform. If updating to the 
latest version of Java does not allow your course to run, 
you can follow one of the following two options. 
 
Option 1 – Adding URL to Exception Site List 
 

1. Click on your Windows Start button. 
2. Click on Control Panel. 
3. Search for "Java". 
4. Click on Java (32-bit) to open the Java Control Panel. 

a. Click the Security tab. 
b. In the Exception Site List section, click on Edit 

Site List. 
c. Click Add and type https://services.geolearning.com 
d. Click OK to close the Exception Site List window. 
e. Click OK to close the Java Control Panel. 
f. Close the Control Panel. 

5. Completely close and reopen your browser.  
 
Open your course and click Run on the Security Warning. 
Proceed through the course as instructed. 

 

Option 2 – Setting Java Security to Medium 
 

1. Click on your Windows Start button. 
2. Click on Control Panel. 
3.  Search for "Java". 
4. Click on Java (32-bit) to open the Java Control Panel. 

a. Click the Security tab. 
b. Lower your security settings to Medium.* 
c. Click OK to close out the Java Control Panel. 
d. Close the Control Panel. 

5. Completely close and reopen your browser. 
*Medium security level is available in version 7 or lower. 
 
Open your course and click Run on the Security Warning. 
Proceed through the course as instructed. 
 
 

https://services.geolearning.com/
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ADOBE FLASH PLUGIN IN FIREFOX 
In this scenario, when launching courses in Mozilla 
Firefox, users receive a browser message that reads 
“The Adobe Flash plugin has crashed. Reload the page 
to try again.” In the reported instances, the courses in 
question do not actually require Flash to run.  
 

The workaround is to temporarily disable the Flash 
plugin while taking the course. 
• Click the Open Menu icon 
• Navigate to Add-ons > Plugins 
• Locate the Shockwave Flash plugin and select 

Never Activate from the dropdown menu. 
Once the course(s) in question are completed, the 
plugin can be reactivated by selecting Always Activate 
or Never Activate from the plugin menu. 
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